Bull Atos Technologies

AIX Open Source Archives

2019/08/02

How to use Bull Freeware

Introduction

This page is aimed to explain the features and limitations of this website and how it should be used. Feel free to send us a mail via the Contact page if you need more information.

Versions of AIX

Except some packages (GCC mainly, but also: CMake & PostgreSQL), all packages built on a version of AIX are compatible with higher versions of AIX.
More precisely, all recent packages are built on AIX version N = 6.1 and are thus compatible with AIX 7.1 and 7.2, with any TL (Technical Level ("oslevel -s")), except the 3 packages listed above.

Dependencies

Nearly all packages depend on other packages. A list of dependencies appears on the appropriate RPM page when you are ready to download the binary RPMs of a package.
Since we have no idea about which packages are already installed on your machine, we provide you the list of all the latest versions of the dependencies needed by the package you plan to download.
Dependencies of an installed package can be shown by command:

rpm -qR ncurses

Example

Let say that you need a new package named A, which appears with only one version: v1.1. Package A v1.1 depends on packages B, C (version >= 3.2), and D.
And versions B v2.1 & v2.2 , C v3.1 & v3.2 & v3.3 , D v4.2.0 & v4.5.0 are available in the Bull Freeware repository.
We will suggest you as dependencies the newest version of each: B v2.2, C v3.3, and D v4.5.0 . However, you are not required to install these newest versions ! You may have a different choice.
Let say that you have packages B v2.0 and C v3.1 installed on your system, but not D.
That means that you do not need to install a new version of B but that you have to install at least version v3.2 of package C and that you need at least D v4.2.0 .
So, about B, either you want to stay with your older version v2.0 or you want to update it to the newest version v2.2.
About C, you can choose amongst v3.2 and v3.3 .
And, about D, why not version 4.5.0 ? It should provide more features and less bugs!

Choosing the right packages

That depends if you want to apply as few changes as possible (minimizing the risk of breaking your environment) or if you are ready to move to the last updated version of each package (which may make new issues appear).
We suggest you to first download the newest version of the package that you need and to try to install it on your system.
The "rpm -i" (or "rpm -U") command will provide you a list of the packages that are missing, possibly with some minimal version.
This way, you'll know exactly which new packages (or which new versions of an already installed package) are required.
Then, you may download the full .zip file containing all the suggested dependencies, with the last version for each.

yum

As you may have understood, yum is not available (yet ! We are planning on a deployment soon).
The diffecrences are as follow :
Yum is able to know which packages are already installed on your machine. So he is able to know which minimum version of each dependency is required, and it may not propose to update a package if it is already installed and satisfies the requirements of the new package to be installed. However, it will (as we do) propose to install the newest version of each missing dependency.

About GCC

Now, what about the special case of GCC ?
As said above, though nearly all other RPMs built on AIX 6.1 can be installed and used on AIX versions greater or equal to 6.1, GCC RPMs can be installed and used on only ONE version of AIX: the version it was built for.
So: "gcc-8.3.0-1 built for aix7.1", aka gcc-8.3.0-1.aix7.1.ppc.rpm RPM binary file, can be installed only on AIX 7.1. And gcc-8.3.0-1.aix6.1.ppc.rpm can be installed and used only on AIX 6.1.
All GCC versions (at least from 4.8.4 till 8.3 and further) do provide libstdc++.a(libstdc++.so.6) and libgcc_s.a(shr.o) and are compatible.
Unless you haven't already installed a full version of GCC (compiler and libraries), you have to download and install GCC libraries separately and according to your specific needs. >hoose the version of GCC that fits your needs, and take the version of AIX for GCC which is the same as the version of your AIX system where you want to install ncurses.